Psexec giving the system cannot find the specified file

I am trying to run this from my win7 CMD (as Admin):

psexec IpAddress -u domain\user -p pword c:\Autobatch\ClientJobSender.exe http://reportserver.net:8070/JobExecutor.asmx c:\AutoBatch\backup\trigger.xml 

but I get the error "Error in the system was not found."

I also tried this as follows:

 psexec IpAddress -u domain\user -p pword c:\Autobatch\ClientJobSender.exe http://reportserver.net:8070/JobExecutor.asmx c:\AutoBatch\backup\trigger.xml 

but get an unknown user or an invalid password.

What is strange is that I can connect via remote desktop with the same IP address and user / pass.

+4
cmd remote-desktop psexec
source share
4 answers

Make sure the server has the following settings:

 a) Admin share is enabled: run services.msc and check the Service "Server" is enabled b) Add the key for the share in the registry and restart: reg add "HKLM\SYSTEM\CurrentControlSet\Services\LanmanServer\Parameters" /v AutoShareServer /t REG_DWORD /d 1 

And then use:

 psexec \\IpAddress -u domain\user -p pword -w "c:\Autobatch" "ClientJobSender.exe http://reportserver.net:8070/JobExecutor.asmx c:\AutoBatch\backup\trigger.xml" 
+4
source share

In fact, I do not see the difference between the two teams. However, the error of the first command is due to the fact that your syntax is incorrect. You have to use

 PsExec \\abcd ... 

instead

 PsExec abcd ... 
+2
source share

I got it for work by raising a local batch file for execution with administrator rights, that is, the terminal window worked with administrator rights.

+1
source share

If you are trying to use automation services, you can use ClientJobSender.exe on the local computer (or on the computer on which you set up scheduling). Just copy ClientJobSender.exe and the corresponding configuration file from the installation package to the scheduler server and specify it locally.

0
source share

All Articles